在CentOS7中安装jekyll是提示要使用 Ruby 2.4.3 以上版本,当当前没有办法找到该版本的RPM安装包,只好自己动手编译一个了。

编译方法

yum install -y rpm-build rpmdevtools readline-devel ncurses-devel gdbm-devel tcl-devel openssl-devel db4-devel byacc libyaml-devel libffi-devel make glibc-devel gcc checksec cmake  autoconf git multilib-rpm-config systemtap-sdt-devel
rpmdev-setuptree
rpmbuild -ba ruby.spec --nocheck --define="dist .el7"
ARCH=`uname -m`
KERNEL_REL=`uname -r`
KERNEL_TMP=${KERNEL_REL%.$ARCH}
DISTRIB=${KERNEL_TMP##*.}
yum localinstall ~/rpmbuild/RPMS/${ARCH}/${RUBY_VER}${RUBY_SUBVER}-1.${DISTRIB}.${ARCH}.rpm

下载地址

https://pan.baidu.com/s/1qZ97ht6

ruby-rpm Git地址

https://github.com/XieXianbin/ruby-rpm

完毕。